Network performance has been restored. We are marking this incident as resolved.
Posted Jun 24, 2026 - 10:05 EDT
Monitoring
The new resources are in place and network performance is gradually improving. We will continue to monitor network activity for affected sites.
Posted Jun 23, 2026 - 14:23 EDT
Identified
We are deploying additional temporary resources to better handle the increased network load and help reduce the impact size of the issue. Please bear with us as these resources are spun up.
Posted Jun 23, 2026 - 13:42 EDT
Investigating
We are investigating a new incident affecting the same subset of customer sites.
Posted Jun 23, 2026 - 13:14 EDT
Monitoring
The fix has completed rolling out and we are monitoring the results.
Posted Jun 23, 2026 - 11:26 EDT
Update
The source of the issue has been mitigated, and a fix to restore network performance is being rolled out to the affected sites
Posted Jun 23, 2026 - 10:30 EDT
Identified
We are aware of connection issues affecting some of our customers' sites, and we believe we have identified the source of the issue. Mitigation efforts are underway.
Posted Jun 23, 2026 - 10:15 EDT
This incident affected: Modern Hosting (Low-Level Compute).